BUSCAR

domingo, 18 de agosto de 2019

Juego Vamos a Multiplicar Realizado en Excel


Este es un sencillo juego realizado en Excel. Es una ayuda para los mas pequeños ya que la gran mayoría le cuesta mucho aprender las tablas de multiplicar.
Recuerda debes habilitar las macros.
Si quieres ver como fue realizado solo vas  a la ficha Desarrollador, Visual Basic y puedes ver el código, que es muy sencillo.

Link para descargar el juego:

Recuerda si vas a utilizar este sencillo programa contar donde lo obtuviste, si lo vas a modificar compártelo así de simple


domingo, 11 de agosto de 2019

Software Educativo Practiquemos las tablas PowerPoint



Una forma muy sencilla de practicar las tablas para los mas pequeños es mediante juegos.
Realice un sencillo juego en PowerPoint que va a ayudar a los pequeños a practicar o repasar las tablas.
Si vas a la ficha programador vas a ver la siguientes lineas de código:
Botón Jugar:

Private Sub CommandButton1_Click()
Slide2.TextBox1.Text = ""
Slide2.TextBox2.Text = ""
Slide2.TextBox3.Text = ""
Slide2.Label1.Caption = "0"
Slide2.Label2.Caption = "0"
Slide2.Label3.Caption = "0"


SlideShowWindows(Index:=1).View.Next


Botón nuevo numero:
Dim total As Integer // variable global

Private Sub CommandButton1_Click()
Dim n1, n2 As Integer

Randomize


n1 = (Str(Int(Rnd() * 12 + 1)))
n2 = (Str(Int(Rnd() * 10 + 1)))
TextBox1.Text = n1
TextBox2.Text = n2
total = n1 * n2

Label1.Caption = Label1.Caption + 1
      

End Sub

Botón Comprobar:

Private Sub CommandButton2_Click()



If TextBox3.Text = "" Then
MsgBox "Debes ingresar el resulatado "

ElseIf TextBox3.Text = total Then

Label2.Caption = Label2.Caption + 1


TextBox1.Text = ""
TextBox2.Text = ""
TextBox3.Text = ""

ElseIf IsNumeric(TextBox1.Text <> total) Then
MsgBox "Mal! El resultado es " & total
Label3.Caption = Label3.Caption + 1
TextBox1.Text = ""
TextBox2.Text = ""
TextBox3.Text = ""
End If

Es muy sencillo de hacer y con solo unas lineas de código.
Si gustas puedes descargarlo desde el siguiente link
Recuerda si lo modificas o adaptas no olvides contar donde lo obtuviste, ademas fue totalmente gratis así que puedes compartirlo con otros.
Link



sábado, 20 de julio de 2019

Efecto Splash con PowerPoint


Puedes descargar esta presentación desde el siguiente link:






Si deseas aprender hacer este efecto déjemelo saber en los comentarios y pronto subiré el tutorial de como hacerlo. 

lunes, 13 de mayo de 2019

Como convertir PowerPoint a HTML5


Existe un genial complemento que de una forma muy sencilla va a convertir nuestras presentaciones de PowerPoint a HTML5, me refiero a iSpring free
Que es iSpring free es un convertidor gratuito de PowerPoint  a Flash y HTML5.
Para obtener este excelente complemento solo debes ingresar a su pagina y solamente ingresando tu correo vas a obtener el link para descargar e instalar iSpring free.
Ahora podrás compartir mas fácilmente tus presentaciones, juegos interactivos creados en PowerPoint. Si eres docente esta es una genial ayuda. 
Va a crear un archivo index.html ademas una carpeta data, estos dos archivos siempre deben estar juntos.
Podrás Conservar  las animaciones, transiciones, audio y vídeo. 
Si deseas puedes ver el siguiente vídeo allí te  explico paso a paso  como obtener este genial complemento para PowerPoint



Puedes acceder a su pagina:


Ademas puedes descargar la presentación convertida en HTML5 


Puedes jugar online 





miércoles, 8 de mayo de 2019

Planilla calcular Tasa Metabolismo Basal -TMB - Excel


Esta practica planilla realizada en Excel nos ayudara a calcular nuestro IMC y  TMB.
Así obtener nuestra Tasa de Metabolismo Basal.

Que es es el IMC - Indice de Masa Corporal

Es el indice de masa corporal, es un método utilizado para estimar la cantidad de grasa corporal que posee una persona, y determinar por tanto si su peso esta dentro del rango normal o por el contrario se posee sobrepeso o delgadez.

Que es TMB - Tasa de Metabolismo Basal 

Es un índice que determina las necesidades energéticas mínimas de una persona para el correcto funcionamiento del organismo, como por ejemplo, el desarrollo y funcionamiento de los órganos o la regulación de la temperatura corporal.

Como se calcula el IMC

IMC= PESO/ALTURA(M)^2

Como se calcula el TMB

Primero debemos de encontrar nuestros requerimientos diarios, y para ello usaremos la fórmula de Harris-Benedict modificada para conseguir una aproximación:

Hombres TMB = (10 x peso en kg) + (6,25 × altura en cm) – (5 × edad en años) + 5
Mujeres TMB = (10 x peso en kg) + (6,25 × altura en cm) – (5 × edad en años) – 161


Estos cálculos nos darán nuestro gasto calórico en reposo (sin hacer nada, únicamente por estar vivos) por ello deberemos de multiplicarlo por el nivel de actividad según realicemos en el día:


  • Sedentario, sin realizar ejercicio: 1,2
  • Ligera actividad, ejercicio 1 o 3 veces por semana: 1,37
  • Moderada actividad, entrenamiento 3 a 5 días semana: 1,55
  • Intensa actividad, entrenamiento 6 o 7 días semana: 1,72
  • Deportistas y atletas: 1,9
Para realización de esta planilla hemos utilizado la función Si , BuscarV, Validación de datos(Lista desplegable) y unas  simples formulas matemáticas.
En la celda D4 se creo una lista desplegable cuyos datos se extrajeron de las celdas T2;T3
Podemos escoger sexo : 
Hombre
Mujer

En la celda D6 también tenemos una lista desplegable que corresponde al rango de celdas U2:U6
Actividad física:
SEDENTARIO POCO EJERCICIO
POCO ACTIVO EJERCICIO 1 - 3 VECES POR SEMANA
MEDIANAMENTE ACTIVO EJERCICIO  3 - 5 VECES POR SEMANA
MUY ACTIVO EJERCICIO 6 - 7 VECES POR SEMANA
EXTRA ACTIVO EJERCICIOS MUY INTENSOS

Solamente debes agregar los datos que se encuentran en las siguientes celdas:
EDAD      Celda D8
PESO       Celda D10
ALTURA Celda D12

Ya ingresados estos datos nos calcula en forma automática nuestro IMC y TMB.
Formulas utilizadas

Calcular IMC
En la celda H8

=SI.ERROR(D10/(D12*D12);"")

Estado Nutricional 

Para ello en la  hoja ESTADO que esta oculta se ha creado una tabla con el nombre IMCDATOS



En la celda F12 esta la siguiente formula:

=SI(H8="";"";BUSCARV(H8;IMCDATOS;3))

Vamos a entender esta sencilla formula Si la celda H8 esta vacía no se ha calculado el IMC la celda F12 estará vacía y no mostrara el error  #valor.
Ahora si en esta celda H8 se ha calculado el IMC entonces va hacer una búsqueda en la Tabla IMCDATOS entre el IMC MÍNIMO  y el IMC  MÁXIMO, cuando de con este dato nos va a indicar el estado nutricional  que se encuentra en la columna 3.

En la Celda L5 allí se hace el calculo de TMB
Para ello nuevamente utilizaremos la función Si :

=SI(D8="";"";SI(D4="HOMBRE";(10*D10)+(6,25*E12)-(5*D8)+5;SI(D4="MUJER";(10*D10)+(6,25*E12)-(5*D8)-161)))

Para hacer este calculo se utiliza la formula:
Hombres TMB = (10 x peso en kg) + (6,25 × altura en cm) – (5 × edad en años) + 5
Mujeres TMB = (10 x peso en kg) + (6,25 × altura en cm) – (5 × edad en años) – 161

Para ello debe escoger el sexo en este caso HOMBRE o MUJER este dato ya debe estar ingresado en la celda D4
Si la celda D8 esta vacía no va a  calcular el TMB.
Ahora si esta celda tiene ingresado el dato HOMBRE o MUJER va aplicar la formula correspondiente para cada sexo.
Para calcular las calorías diarias debemos utilizar el siguiente criterio: 

  • Sedentario, sin realizar ejercicio: 1,2
  • Ligera actividad, ejercicio 1 o 3 veces por semana: 1,37
  • Moderada actividad, entrenamiento 3 a 5 días semana: 1,55
  • Intensa actividad, entrenamiento 6 o 7 días semana: 1,72
  • Deportistas y atletas: 1,9
Usaremos la siguiente formula 

=SI(L5="";"";SI(D6="SEDENTARIO POCO EJERCICIO";(L5*1,2);SI(D6="POCO ACTIVO EJERCICIO 1 - 3 VECES POR SEMANA";(L5*1,375);SI(D6="MEDIANAMENTE ACTIVO EJERCICIO  3 - 5 VECES POR SEMANA";(L5*1,55);SI(D6="MUY ACTIVO EJERCICIO 6 - 7 VECES POR SEMANA";(L5*1,725);SI(D6="EXTRA ACTIVO EJERCICIOS MUY INTENSOS";(L5*1,9)))))))

Si la celda L5 esta vacía, donde hemos calculado el TMB no mostrara  nada.
Si esta celda tiene el calculo del TMB entonces dependiendo de la actividad física,  para ello lo  hemos seleccionado la celda D6 va hacer los diferentes calculo.
Si  soy mujer  y tengo una vida sedentaria entonces a mi TMB se le va aplicar un 1,2 y asi sucesivamente dependiendo de nuestro sexo y actividad física.

Calcular calorías para adelgazar 

Es una estimación del 20 %
Celda L10

=SI(L5="";"";(L5*80%))

Calorías para subir de peso 

Estimación del 25%
Celda L12

=SI(L5="";"";(L5*125%))

Calcular Macronutrientes 

Este cálculos debemos hacerlos sobre la base de las calorías diarias

Calcular Carbohidratos diarios 
=SI(L8="";"";((L8)-(L17*4)-(L19*9))/4)

Para calcular las Proteínas diarias se aplica la siguiente formula:

=SI(D10="";"";(2*D10))
 Esto quiere decir que a nuestro peso que esta ingresado en la celda D10 debemos multiplicar por 2

Para el calculo de la grasa 
=SI(D10="";"";(1*D10))

Ahora a nuestro peso debemos multiplicarlo por 1
 Para una mejor comprensión de este tema puedes leer el siguiente articulo


Por ultimo solo se han utilizado dos simples macros una para limpiar algunas celdas, y la otra para ocultar la barra de formulas.

Para limpiar 

Sub LIMPIAR()
Range("D4,D6,D8,D10,D12").Select
Selection.ClearContents
End Sub

Para desactivar la barra de formulas:

Esto debes hacerlo en ThisWorkbook en open 

Private Sub Workbook_Open()
Application.DisplayFormulaBar = False
End Sub


Puedes descargar el archivo desde este link






























martes, 7 de mayo de 2019

Juego de lógica en Excel - Adivina un numero




Este sencillo juego de lógica   realizado en Excel consiste en que debes adivinar un numero comprendido entre 1 y el 100.
Para ir generando el numero en forma aleatoria que debes adivinar  se ha utilizado la función Random  osea RND.
Es muy sencilla esta función solo debemos escribir estas instrucciones:
Primero creamos una variable y luego el rango o celda donde queremos que se genere  nuestro numero aleatorio.


a = Int((Rnd) * 100 + 1)
Range("f12") = a

a    = variable 
Int = Numero entero
Rnd= Función aleatoria
Range= Rango o celda 

Ahora como queremos omitir el numero cero nuestra función queda asi
a= Int(Rnd)*100 + 1
Range("f12")=a

Ahora vamos a nuestra hoja  JUEGO.
Queremos que el numero aleatorio se genere en la celda F12.
Ahora vamos a insertar un modulo para ello vamos a ir  a la pestaña Programador.
O simplemente con la tecla ALT F11 para abrir el editor VBA.
Ahora vamos a insertar un modulo vamos a escribir las siguientes lineas de codigo

Sub numero()
Randomize
a = Int((Rnd) * 100 + 1)
Range("f12") = a
Range("E5,B4").Select
Selection.ClearContents
End Sub

Esta macro nos va a generar un numero aleatorio entre el 1 y el 100.
Para iniciar el código se ha utilizado  Randomize cada vez que abramos nuestro Libro al momento de iniciar un nuevo juego se van a ir generando distintos números aleatorios. Con esto se evita que siempre al iniciar el juego se van a repetir los mismos números que en la partida anterior.
Ademas esta macro Limpia las  celdas E5 donde vamos a ingresar un numero,  y la celda B4 esta celda es donde va a ir acumulando el numero de intentos.
Entonces esta macro debemos asignarla al botón Jugar.

Ahora para validar el numero de intentos y las pistas que me debe entregar, si el numero es mayor o menor  solo debemos  escribir la siguiente función en la celda E10 que después debemos ocultar.
Utilizaremos la función SI.

=SI(E5=0;"Debes presionar boton Jugar , escribir un numero celda E:5";SI(E5<F12;"El numero es mayor";SI(E5>F12;"El numero es menor";"¡Has ganado!")))

Si la celda E5 es igual a cero estan las primeras instrucciones "Debes presionar botón Jugar , escribir un numero celda E:5"
Ahora si la celda E5 es mayor a F12 aquí es donde aparece nuestro numero aleatorio, nos mostrara este mensaje " El numero es mayor"
Por ultimo Si la celda E5 es menor F12 "El numero es menor" si no se cumple esta condición este quiere decir que ambos celdas son iguales ...simplemente has ganado el juego.
Esta función SI esta anidada con otra función SI.

Ahora solo nos falta nuestro marcador de intentos.

Los intentos se van a ir acumulando en la celda B4
Para ello vamos a escribir el siguiente código en:  
Hoja1(JUEGO)
 Worksheet_Calculate

Yo en esta ocacion use la opcion Calculate de la hoja.


 Private Sub Worksheet_Calculate()
contadorIncorrecto = Range("B4")
If Range("E10") = "El numero es mayor" Or Range("E10") = "El numero es menor" Then
contadorIncorrecto = contadorIncorrecto + 1
Range("B4") = contadorIncorrecto
End If
If Range("F12") = Range("E5") Then
MsgBox ("Ganaste el juego")
Range("E5,B4").Select
Selection.ClearContents
End If
If Range("B4") = 6 Then
MsgBox ("Perdiste juego")
Range("E5,B4").Select
Selection.ClearContents
End If

contadorIncorrecto = variable
Esta variable se va a ir acumulando en la celda B4
If es una condición, si en la celda E10 me marca "El numero es mayor" Or osea o la celda E10 es igual a " El numero es menor" entonces se va a incrementar un punto a la celda B4 
contadorIncorrecto = contadorIncorrecto + 1
Acumula este resultado en la celda B4
End if    Aquí termina esta instrucción.

Ahora si la celda f12 es igual  a la celda E5  esto quiere decir que has ganado el juego.
Sale un mensaje  MsgBox ("Ganaste el juego")
Range("E5,B4").Select
Selection.ClearContents   Se limpian estas celdas
End if fin de esta instrucción.
Si la celda B4 = 6  este es el numero de intentos entonces...Perdiste el juego.
MsgBox ("Perdiste juego") mensaje
Range("E5,B4").Select
Selection.ClearContents  Limpia estas celdas
End If

Para que muestre los mensajes en una forma  en este caso Llamada Ovalada 3 solo debes seleccionar la forma vas a la barra de herramientas allí escribes = E10 así se vincula lo que esta en la celda a esa forma.

Para desactivar la barra de formulas:

Esto debes hacerlo en ThisWorkbook en open 

Private Sub Workbook_Open()
Application.DisplayFormulaBar = False
End Sub

Listo ya esta terminado nuestro juego si deseas puedes modificarlo.
Si te ha gustado déjame un comentario. 
Si deseas puedes descargar este juego completo de este link
























sábado, 4 de mayo de 2019

Juego del gato - Tres en raya - Triqui - En Excel con Macros


Este sencillo juego fue  realizado en Excel donde se utilizaron las funciones SI ademas la función  Y y la función O

En la celda J5 que corresponde al JUGADOR 1 debes escribir la siguiente función  SI anidada con la función Y ademas de la función O: 


 =SI(O(Y($D$5="X";$D$8="X";$D$11="X");Y($E$5="X";$E$8="X";$E$11="X");Y($F$5="X";$F$8="X";$F$11="X");Y($D$5="X";$E$5="X";$F$5="X");Y($D$8="X";$E$8="X";$F$8="X");Y($D$11="X";$E$11="X";$F$11="X");Y($D$5="X";$E$8="X";$F$11="X");Y($F$5="X";$E$8="X";$D$11="X"));"GANASTE";"")
En este caso el que gana la partida es la letra X que corresponde al JUGADOR 1
Se evaluaron 8 posibles posibilidades  que ganara la letra X tanto horizontal, vertical y diagonal que en este caso son dos diagonales.

Ahora para que gane la letra O también se van a evaluar las 8 posibles  posibilidades.
Debes escribir en la celda J8 que corresponde al JUGADOR 2 la siguiente función:
 SI anidada con la función Y ademas de la función O:

=SI(O(Y($D$5="O";$D$8="O";$D$11="O");Y($E$5="O";$E$8="O";$E$11="O");Y($F$5="O";$F$8="O";$F$11="O");Y($D$5="O";$E$5="O";$F$5="O");Y($D$8="O";$E$8="O";$F$8="O");Y($D$11="O";$E$11="O";$F$11="O");Y($D$5="O";$E$8="O";$F$11="O");Y($F$5="O";$E$8="O";$D$11="O"));"GANASTE";"")

Ahora para hacer el juego mas interactivo se han creado unas sencillas macros:
Para comenzar un NUEVO JUEGO, lo que hace esta macro es limpiar el rango de celdas que corresponde al Rango("D5:F13")
Ademas  esta macro llama a  la función PUNTOS que vamos a crear en un nuevo modulo. 
Para llamar una función utilizamos la palabra Call de esta forma podemos utilizar una función en cualquier modulo, así  utilizar este código  muchas veces sin volver a escribir las mismas instrucciones. 

Sub LIMPIAR()
Call PUNTOS

Range("D5:F13").Select
Selection.ClearContents

End Sub

Esta macro esta inserta en el modulo1.

En la macro anterior  se ha llamado a la función Puntos.
Esta función se crea de la siguiente forma debes insertar un modulo
Escribes lo siguiente:

Function PUNTOS()
JUGADOR1 = Range("M5")
JUGADOR2 = Range("M8")
If Range("J5") = "GANASTE" Then
JUGADOR1 = JUGADOR1 + 1
Range("M5") = JUGADOR1
End If
If Range("J8") = "GANASTE" Then
JUGADOR2 = JUGADOR2 + 1
Range("M8") = JUGADOR2
End If
End Function

En la celda M5 se va acumulando el puntaje del Jugador 1
Si en la celda J5 dice "GANASTE" se suma un punto al jugador 1
Para ello se ha utilizado un if si se cumple esta condición se suma 1 punto al JUGAR1  
En la celda M8 se va acumulando el puntaje del Jugador 2
Si en la celda J5 dice "GANASTE" se suma un punto al jugador 2
Aquí se utiliza una segunda condición if si esta se cumple se acumula 1 punto al JUGADOR2 
Esta función esta implementada en el modulo2

Por ultimo para limpiar el tablero de PUNTOS 
En el modulo3 corresponde a  LIMPIAR TABLERO:
Sub LIMPIAR_TABLERO()
Range("M5,M8").Select
Selection.ClearContents
End Sub

Para desactivar la barra de formulas:

Esto debes hacerlo en ThisWorkbook en open 

Private Sub Workbook_Open()
Application.DisplayFormulaBar = False
End Sub

Ya esta casi listo nuestro juego ahora  solo falta que al momento de escribir letra X o O estan cambien de color esto se hizo de una forma muy sencilla utilizando Formato Condicional:
Seleccionas todo el rango D5:F13 vas a la barra de herramientas inicio...Estilos:
Formato Condicional
Resaltar reglas de Celdas------> Texto que contiene letra, seleccionas esta opcion.
Escribes la letra X






Escoges formato personalizado y cambias el color de la fuente:



Haces el  mismo procedimiento  para letra O.


Puedes descargar el juego del siguiente Link: